UK: 01564  783  192
Int: +44 1564 783 192

Close

If you know the part number you require, enter it here

'The Legend Rides On' - the most magnificent Royal Enfield book

A fabulous visual celebration of Royal Enfield motorcycles - very limited suplies!

more details
Seats

more details
View Hitchcocks from inside the building, click here and explore all areas
A behind the scenes look at Hitchcocks Motorcycles

« Back

Bullet 500 engine start/runs with ignition sw in off position

Post a ReplyPost a Reply

Page  1 

Bullet 500 engine start/runs with ignition sw in off position
Started at 06:26pm on the 20th April, 2017 by tippi
tippi Subject: Bullet 500 engine start/runs with ignition sw in off position
Hello all, Today I wanted to stop the engine (Bullet 500 kick) by turning the ignition sw to off, but, big surprise the engine kept running. By means of second gear and clutch release during idling I stopped it - next miracle to follow: with the ignition sw still in the off Position, it was possible to start the engine. I dont know much about the electric wiring in my Bullet because it was partly modified by the previous owner, I can see that an electronic rectifier is used, and there are two cable connectors (1xpositive and 1xground plug) running from the battery to the harnesses/circuitry (which are hidden in the left tool box). With the ground plug disconnected, the engine can be started, but as I said, I cant stop it. To all experts in electrics - please, please help ... Thank you, Peter
Posted: 06:26pm 20th April, 2017
Adrian Subject: Bullet 500 engine start/runs with ignition sw in off position
Hmm, wear in the switch contacts could leave a trail of metallic particles between the contacts bypassing the insulation in the switch body, turning it into an on/on switch? New ignition switches are cheap enough, get another one of the correct year for your bike from our hosts and try again? A.
Posted: 08:52pm 20th April, 2017
Leon Novello Subject: Bullet 500 engine start/runs with ignition sw in off position
Old bikes without an ignition switch were stopped by using the valve lifter. Or, until a new switch is fitted try the kill switch on the handlebar.
Posted: 02:05am 21st April, 2017
tippi Subject: Bullet 500 engine start/runs with ignition sw in off position
Hello again - problem solved: I have changed a bad cable connector and cleaned the contacts in the ign. sw. Herre is a good instruction regarding sw. dismantling: http://www.team-bhp.com/forum/motorbikes/158133-diy-royal-enfield-bullet-ignition-key-assembly-cleaning-replacing.html Thank you, regards Peter
Posted: 04:14pm 22nd April, 2017

Page  1 


Post a ReplyPost a Reply
Opening times: Monday - Friday 9am - 6pm | Closed: Saturday and Sunday
IF YOU ARE NEW TO THIS SITE AND WOULD LIKE INSTRUCTIONS ON HOW TO USE AND NAVIGATE IT, PLEASE CLICK HERE.
Units 7 & 8, Rosemary Court, Oldwich Lane West, Chadwick End, Solihull, B93 0EY, UK

© Hitchcocks Motorcycles Ltd. 2010 | Terms & Conditions

Back to top