UK: 01564  783  192
Int: +44 1564 783 192

« Back

Missing issue with Amal and Sr magneto

Post a ReplyPost a Reply

Page  1 

Missing issue with Amal and Sr magneto
Started at 12:18pm on the 6th June, 2018 by Hercules
Hercules Subject: Missing issue with Amal and Sr magneto
Hi All, I have 1959 Royal Enfield 350cc. Recently I have installed SR1 Magneto with ATD to my Bullet . It is working good with Mikuni carburettor. But when I put my AMAL 376 monobloc, I’m getting missing issue. And also Amal was working good with Delco point ignition . Missing happens with Amal and Sr combination. Any idea why it is happening . Thanks in advance , Selvam
Posted: 12:18pm 6th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
Also fuel is rich and plug gets burn out. We have already tried adjusting the Air screw .
Posted: 03:10pm 6th June, 2018
Mark M Subject: Missing issue with Amal and Sr magneto
I think when Hercules says Delco he means distributor. I believe this is a term used in India? Just for clarification.

REgards, Mark
Posted: 03:18pm 6th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
HI Mark, Exactly you are correct. It is distributor.
Posted: 03:37pm 6th June, 2018
Mark M Subject: Missing issue with Amal and Sr magneto
This is quite a puzzle! Can you list the jets of the Amal carburettor that is fitted? Main and pilot jet and throttle slide if you can please. I'm wondering if the Amal is jetted too rich and the old distributor was timed wrongly? And perhaps you could explain exactly what the missing problem is, at tickover, half throttle, full throttle?

REgards, Mark
Posted: 04:12pm 6th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
Mark, thanks for your reply. Here is the details. Bore 1:00" (25.40mm) diameter, Main Jet size 180, Slide number 4, Needle jet size 106, Pilot jet size 30 and Needle type C (Part# 376/063 - 95mm long) It is tick over sound. When we start the vehicle and leave in idling it misfire and producing tick over. And also, while riding with half or full throttle it misfire and off. Is there any timing settings or point settings needs to be done with this SR Magneto and Amal combination. Thanks
Posted: 06:46pm 6th June, 2018
Exile Subject: Missing issue with Amal and Sr magneto
"It is working good with Mikuni carburettor...."

There's the answer then.... bin the Amal.
Posted: 07:49pm 6th June, 2018
Mark M Subject: Missing issue with Amal and Sr magneto
The Amal carb you have is actually slightly smaller than the one originally specified (which was 1 & 1/16") and your main jet is also slightly smaller (190 originally) so the richness is odd. The valve and ignition timing should be the same for any carb as they are elements of the overall design taking into account valve lift, compression ratio, piston stroke and bore etc. Is it possible that you have mis-timed the magneto? The advance retard unit is usually set in the full advance position for timing, did you do this? I still don't see why the Micarb works though!

REgards, Mark
Posted: 10:57pm 6th June, 2018
Bullet Whisperer Subject: Missing issue with Amal and Sr magneto
Quote: There's the answer then.... bin the Amal. For anyone wishing to do so, there is a large bin at the end of my lane, feel free ...
Posted: 07:32am 7th June, 2018
Revband Subject: Missing issue with Amal and Sr magneto
And I will happily pay the postage to save going to Paul's bin. ;-)
Posted: 12:45pm 7th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
@Mark, will check whether Magneto is in Full advance and let you know. The Amal which i have is , bought from Ebay UK. And seller said, all spares are exact matching for this carb. I am surprised with your reply, that it should have Main jet 190. Let me check on that too. Thanks
Posted: 01:10pm 7th June, 2018
Mark M Subject: Missing issue with Amal and Sr magneto
Herc, I got those figures from the online Parts Book here. I must admit, I thought the 350 Bullet had a 1" carb, mine does. But it is fitted with a KNR1 'Wader" magneto.

REgards, Mark
Posted: 02:22pm 7th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
Thanks for the info Mark. Ill check and let you know after this weekend.
Posted: 03:20pm 7th June, 2018
Hercules Subject: Missing issue with Amal and Sr magneto
@Mark, Thanks for your time. Issue got resolved. Actually there is a problem with Jet. Now , it is perfect.
Posted: 02:30pm 13th June, 2018

Page  1 


Post a ReplyPost a Reply
Opening times: Monday - Friday 9am - 6pm | Closed: Saturday and Sunday
Units 7 & 8, Rosemary Court, Oldwich Lane West, Chadwick End, Solihull, B93 0EY, UK

© Hitchcocks Motorcycles Ltd. 2010 | Terms & Conditions

Back to top